BlazeMeter long delays in report data

Incident Report for BlazeMeter

Resolved

The incident has been resolved.
Posted Mar 30, 2025 - 12:34 PDT

Update

As of 18:15 UTC, the issue experienced by some customers has been addressed and functionality has been restored. This incident is now resolved.
Posted Mar 30, 2025 - 11:27 PDT

Update

As of TIME_STAMP UTC, the issue experienced by some customers has been addressed and functionality has been restored. This incident is now resolved.
Posted Mar 30, 2025 - 11:26 PDT

Investigating

We are currently investigating this issue.
Posted Mar 30, 2025 - 06:08 PDT
This incident affected: BlazeMeter Platform.